Fatal error: Uncaught exception 'Zend_Log_Exception

Petit nouveau ! | 4 Messages

15 avr. 2016, 15:32

Bonjour à tous,

J'ai cette erreur qui s'affiche lors de mon déploiement sur le serveur Unix:
Fatal error: Uncaught exception 'Zend_Log_Exception' with message '"/appli/hd_/hd_adm/u2/01_01_00.000/_WS/application/../logs/errors.log" cannot be opened with mode "a"' in /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Log/Writer/Stream.php:81
Stack trace:
#0 /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Log/Writer/Stream.php(107): Zend_Log_Writer_Stream->__construct('/appli/hd_/hd_a...', NULL)
#1 [internal function]: Zend_Log_Writer_Stream::factory(Array)
#2 /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Log.php(276): call_user_func(Array, Array)
#3 /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Log.php(169): Zend_Log->_constructFromConfig('writer', Array, 'Zend_Log_Writer')
#4 /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Log.php(504): Zend_Log->_constructWriterFromConfig(Array)
#5 /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Log.php(152): Zend_Log->addWriter(Array)
#6 /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Application/Resource/Log in /appli/hd_/hd_adm/u1/01_01_00.000/_Libraries/Zend/Log/Writer/Stream.php on line 81
D'après ce que j'ai compris le c'est le ficher error.log, il n'arrive pas à ouvrir ou à écrire.
De ce fait, j'ai changé les propriétés du fichier :
-rw-r--r-- => -rwxrwxrwx
j'ai crée le fichier errors.log en utilisant application.ini
resources.log.err.writerName = "Stream"
resources.log.err.writerParams.stream = APPLICATION_PATH "/../logs/errors.log"
resources.log.err.filterName = "Priority"
resources.log.err.filterParams.priority = Zend_Log::WARN
Puis l'enregistrement se fait grâce à ce bout de code dans Bootstrap:

protected function _initLogger() {
$this->bootstrap('log');
$logger = $this->getResource('log');

Zend_Registry::set('Zend_Log', $logger);

}
Dans le message d'erreur, il y a ceci qui s'affiche:
cannot be opened with mode "a"
. J'ai rajouté cette ligne :
resources.log.err.writerParams.mode = "a"
. Mais j'ai toujours le même message qui s'affiche.

Pouvez - vous m'aider ?

Merci d'avance