Forum d'entraide PHPFrance

Venez poser vos questions PHP, MySQL, HTML, CSS, Javascript, Gestion de serveurs à la communauté PHPfrance

Vers le contenu

» Masquer les résultats de la recherche

Recherche dynamique PHPfrance

  1. Effectuez une recherche, les résultats s'afficheront dynamiquement ici.

IIS et WAMP : configuration sur le php.ini

Comment gérer un serveur (Unix, Windows,...)

IIS et WAMP : configuration sur le php.ini

Messagepar AMP 01 Fév 2007, 15:46

Bonjour,

J'ai sur un même serveur IIS6 et Wamp. Un port 8080 sur Apache me permet de les utiliser l'un comme l'autre.
Le problème vient du PHP. Pour Wamp pas de problème, le PHP est fourni et est configurer avec Apache.
Pour IIS, j'ai téléchargé une version plus ancienne de PHP que celui de Wamp. Le problème vient du faite que IIS prend en compte le php.ini de wamp (dans c:\wamp\php) et non celui par défaut (dans C:\windows)...

Comment forcer IIS à utiliser le bon php.ini situé dans le dossier Windows. ?

merci pour vos lumières..

amp
AMP
 

Messagepar Invité 01 Fév 2007, 18:20

Après étude du problème, je suis allé chercher dans les registres de windows :
HKEY_LOCAL_MACHINE\SOFTWARE\PHP
le IniFilePath a été basculé sur le dossier contenant le php.ini de wamp lors de l'installation de ce dernier.
une petite rectification du chemin d'accès sur C:\windows a permis à IIS de retrouver le bon php.ini



:D
Invité
 


Retourner vers Gestion de serveur(s)

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 2 invités