[RESOLU] moteur de recherche HS

as2
Eléphant du PHP | 103 Messages

26 sept. 2023, 11:23

Bonjour,
J'ai un site internet chez free qui marche bien depuis 20 ans.
La technologie des bases de données, c'est le bon vieux mysql (je sais on va me dire passe au mysqli, mais problème je suis vieux maintenant, je sais plus programmer...).
Donc voilà le problème depuis hier : mon moteur de recherche php qui interroge la base de données (et qui fonctionne rapidement depuis 20 ans) est tout à coup très lent, voire même il ne marche plus (alors qu'en local tout fonctionne).
Qu'en pensez-vous ?
Vers quoi je pourrais me tourner pour réparer ce problème très gênant.
La navigation sur le site, alors qu'elle est aussi php/mysql est, elle, toujours très rapide, je vois vraiment pas pourquoi il y a un problème avec le moteur de recherche (que j'ai programmé tout seul, comme tout le site, mais y a 20 ans, ensuite j'ai pas suivi les changements dans les 2 langages php et mysql, je suis à la ramasse, de l'aide me serait la bienvenue)
Cordialement.

Avatar du membre
Administrateur PHPfrance
Administrateur PHPfrance | 9626 Messages

26 sept. 2023, 11:30

Peut être tout simplement que le serveur SQL de Free est surchargé vu que c'est un serveur mutualisé gratuit qui fonctionne en "best-effort" mais il suffit qu'un autre utilisateur ait créé un site très gourmand en ressources pour pénaliser tous les autres...

Il y a quelques années, la manière la + efficace pour attirer l'attention de la personne chez Free qui gérait les pages perso était de poster un message dans le newsgroup : proxad.free.services.pagesperso

Je ne sais pas si c'est toujours d'actualité, mais ça marchait bien :)


A défaut, il faut peut être envisager un changement d'hébergeur car c'est vraiment service minimum chez Free pour la partie pages perso.
Quand tout le reste a échoué, lisez le mode d'emploi...

as2
Eléphant du PHP | 103 Messages

26 sept. 2023, 11:43

Oui, alors, merci de ta réponse, et c'est amusant ce que tu dis là, car j'ai justement posté le même message qu'ici sur le newsgroup : proxad.free.services.pagesperso
Alors, que j'y connais pas grand chose, mais c'est une longue histoire, une fois mon site était complétement en rade, au téléphone, on m'a dit de demander de l'aide sur le newsgroup de free, j'ai eu un mal de chien à comprendre ce que ça voulait dire, et finalement c'est le logiciel Thunderbird qui m'a sauvé la vie, enfin pas tout de suite, car là aussi j'ai eu du mal à me connecter, et d'accèder à un newsgroup, mais comme tu dis, là par contre un technicien m'a depanné, et mon site a été réparé... esperons que ça fera pareil avec le probléme actuel de mon moteur de recherche ...

as2
Eléphant du PHP | 103 Messages

27 sept. 2023, 11:08

Le problème semble résolu (de lui-même)

as2
Eléphant du PHP | 103 Messages

11 oct. 2023, 10:25

Malheureusement non, le problème n'est pas résolu.
Il recommence.
Mon moteur de recherche est trés lent alors que la navigation (elle aussi en php/mysql est rapide).
J'ai contacté les news groups free, j'ai eu des réparations, mais ça recommence ?
Y aurait-il quelque chose à revoir dans mon vieux code ?
Ou faut il que je quitte free, pour un autre hebergeur, lequel me conseillez-vous ?