Demande d'avis général, (serveur NAS + PDO)

Répondre


Cette question est un moyen d’empêcher des soumissions automatisées de formulaires par des robots.
Smileys
:D :) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: =D> #-o =P~ :^o :non: :priere: 8-|
Voir plus de smileys
  Revue du sujet
 

  Étendre la vue Revue du sujet : Demande d'avis général, (serveur NAS + PDO)

Re: Demande d'avis général, (serveur NAS + PDO)

par @rthur » 28 oct. 2021, 13:57

Il va falloir que tu avances d'avantage dans ton debugage.
Quels sont les messages d'erreur ?
Qu'y a-t-il dans les logs ?

Demande d'avis général, (serveur NAS + PDO)

par Aorgerit » 27 oct. 2021, 19:19

J'ai été pris pour une chose : refaire un site de a à z.

Impératifs
- serveur NAS 920+, passant par un freeboxos... donc pas top pour le passage sur un freebox.
- nginx/1.17.10.
- Version de PHP : 7.3.24
- 10.3.29-MariaDB
Toutes les tables sont en utf8-unicode-ci bien évidemment, ainsi qu'en innodb, impec pour le pdo.
Je ne fais que rencontrer des soucis en requêtes pdo, même les plus simples au monde presque.
Je reste donc en temporaire sans PDO réelle, (mysqli est en secours).


Autre point.
j'applique du code via wamp en local, (PHP : 7.3.31), et le lance sur le serveur ensuite, cela tourne en local et sur le serveur.

PB: d'ici, sur le local, et sur le serveur, cela tourne nickel, et sur trois nav différents.
Marche pas en http avec un win32bits en plus.

Mais chez eux cela ne tourne pas, sur un win84 aussi, le pire.

Quelqu'un à des avis sur ces points?

Merci par avance de vos réponses potentielles.