282 résultats trouvés

par Larker
16 mars 2016, 23:08
Forum : PHP débutant
Sujet : Bouton dynamique php
Réponses : 6
Vues : 1596

Re: Bouton dynamique php

D'accord merci pour le lien ! Une question que je me pose, il faut obligatoirement séparé en deux fichiers ? L'ajax d'un coté et l'html du formulaire de l'autre ? Ou bien on peut tout réunir en un fichier ? Concrètement je crois que ça donnerait quelque chose comme ça : <?php if(isset($_SESSION['id'...
par Larker
16 mars 2016, 22:56
Forum : PHP débutant
Sujet : Bouton dynamique php
Réponses : 6
Vues : 1596

Re: Bouton dynamique php

Merci pour ta réponse même si je la redoutais. :/
Je déteste l'ajax, je n'y comprend vraiment rien. Est ce compliquer à faire ? Ou est ce quelque chose de vraiment simple ?
par Larker
16 mars 2016, 15:53
Forum : PHP débutant
Sujet : Bouton dynamique php
Réponses : 6
Vues : 1596

Bouton dynamique php

Bonjour, J'ai actuellement des boutons classiques sur mon site et j'aimerais les rendre plus dynamique. Je m'explique : J'ai un bouton qui permet aux membres de liker un commentaire et je souhaiterais que lorsqu'il clique sur ce bouton, que la couleur du bouton change afin de montrer qu'il a déjà ai...
par Larker
06 janv. 2016, 16:55
Forum : PHP débutant
Sujet : Erreur json lors de l'exécution du script
Réponses : 1
Vues : 247

Erreur json lors de l'exécution du script

Bonjour, J'ai un script qui me permet de récolter les informations présentes sur allociné. Il fonctionnait très bien jusqu'à ce que j'ai le message d'erreur suivant : An JSON error (5) occurred when converting data: Malformed UTF-8 characters, possibly incorrectly encoded. Voici mon code : <?php //i...
par Larker
13 déc. 2015, 22:27
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

D'accord merci pour toute ton aide en tout cas !
par Larker
13 déc. 2015, 18:34
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

Ah c'est bon ça fonctionne ! Tu avais raison en fait. Ma requête précisait uniquement les 20 derniers films ajoutés. Sauf qu'il n'y avait pas de problèmes d'images pour celles ci. Donc en étendant le nombre de films à afficher c'est bon ça fonctionne. Seul problème quand je veux en afficher une gros...
par Larker
13 déc. 2015, 18:15
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

Oui justement le but est d'afficher les données quand les images retournent une erreur 404, car il s'agira des affiches de films à modifier car elles sont vides ou en l’occurrence elles affichent une image par défaut.
par Larker
13 déc. 2015, 18:03
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

Je ne sais pas du tout d'où pourrait venir l'erreur. Il doit manquer quelque chose. Ne faudrait-il pas rajouter getimagesize ?
par Larker
13 déc. 2015, 17:42
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

J'ai essayé avec des echo ça fonctionne correctement. Donc je ne vois pas d'où pourrait venir le problème surtout que ça ne m'affiche absolument rien, même pas de message d'erreur.
par Larker
13 déc. 2015, 17:28
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

Bonne question, je fais à chaque fois comme ça vu qu'en générale je ferme pour laisser du html.
par Larker
13 déc. 2015, 17:18
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

D'accord merci ! J'ai testé ça mais ça n'a pas l'air de fonctionner : <?php $stmt = $bdd->prepare("SELECT id, titre, img FROM `fiche_film` WHERE `active` = '1' ORDER BY `id` ASC LIMIT 0,20"); if (!$stmt->execute()) { echo 'ERREUR'; exit; //pas obligatoire } while ($getAffiche = $stmt->fetch()) {?> <...
par Larker
13 déc. 2015, 16:56
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

Et bien j'ai envie de dire que ça fonctionne ! :D Merci !!! Par contre dernière petite question : Si je veux afficher avec une boucle toutes les images que je remplace avec mon image empty c'est possible ? Sa sera plus facile comme ça pour les remplacer que de devoir chercher les films qui n'ont pas...
par Larker
13 déc. 2015, 16:03
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

D'accord merci pour votre aide. Le problème c'est qu'avec Ascla on a essayé le code de or1 mais que ça ne fonctionnait pas. <?php $lien = curl_init($getAffiche['img']); //On stocke le lien dans $lien curl_exec($lien); //On éxécute la fonction magique if (curl_errno($lien)) // Si il y a une erreur { ...
par Larker
12 déc. 2015, 20:47
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

Oui je comprends bien que ça renvoie une erreur car l'image n'existe plus, ça renvoie donc l'image empty.gif présent sur les serveurs d'allociné. Sauf que je voudrais mettre ma propre image quand l'image ne se charge pas. Jusque là tout ce qu'on a testé ne fonctionne pas et c'est assez étrange.
par Larker
12 déc. 2015, 19:59
Forum : PHP débutant
Sujet : Question Api et problème d'images
Réponses : 48
Vues : 3286

Re: Question Api et problème d'images

Merci vraiment pour ton aide Ascla. L'erreur suivante apparait: Warning: getimagesize(http://fr.web.img3.acsta.net/pictures/15/05/05/09/06/126445.jpg): failed to open stream: HTTP request failed! HTTP/1.0 404 Not Found in /public_html/accueil/modules/module-films.php on line 25 La ligne 25 : $img = ...
Nous sommes le 27 sept. 2020, 15:36