Upgrade Symfony 3.4 vers 4.0

Petit nouveau ! | 1 Messages

29 janv. 2020, 14:19

Bonjour à tous,

Actuellement, je migre un projet symfony 3.4 vers 4.0.

J'ai géré les nombreuses dépréciations (13 ), en suivant la doc officielle.

Malheureusement, l'étape ultime du composer update ne passe pas

Voilà, le message d'erreur indiqué.

Code : Tout sélectionner

Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. Problem 1 - Conclusion: don't install symfony/symfony v4.4.3 - Conclusion: don't install symfony/symfony v4.4.2 - Conclusion: don't install symfony/symfony v4.4.1 - Conclusion: don't install symfony/symfony v4.4.0 - Conclusion: don't install symfony/symfony v4.3.10 - Conclusion: don't install symfony/symfony v4.3.9 - Conclusion: don't install symfony/symfony v4.3.8 - Conclusion: don't install symfony/symfony v4.3.7 - Conclusion: don't install symfony/symfony v4.3.6 - Conclusion: don't install symfony/symfony v4.3.5 - Conclusion: don't install symfony/symfony v4.3.4 - Conclusion: don't install symfony/symfony v4.3.3 - Conclusion: don't install symfony/symfony v4.3.2 - Conclusion: don't install symfony/symfony v4.3.1 - Conclusion: don't install symfony/symfony v4.3.0 - Conclusion: remove sensio/distribution-bundle v5.0.25 - Conclusion: don't install sensio/distribution-bundle v5.0.25 - Conclusion: don't install symfony/symfony v4.2.12 - Conclusion: don't install symfony/symfony v4.2.11 - Conclusion: don't install symfony/symfony v4.2.10 - Conclusion: don't install symfony/symfony v4.2.9 - Conclusion: don't install symfony/symfony v4.2.8 - Conclusion: don't install symfony/symfony v4.2.7 - Conclusion: don't install symfony/symfony v4.2.6 - Conclusion: don't install symfony/symfony v4.2.5 - Conclusion: don't install symfony/symfony v4.2.4 - Conclusion: don't install symfony/symfony v4.2.3 - Conclusion: don't install symfony/symfony v4.2.2 - Conclusion: don't install symfony/symfony v4.2.1 - Conclusion: don't install symfony/symfony v4.2.0 - Conclusion: don't install symfony/symfony v4.1.13 - Conclusion: don't install symfony/symfony v4.1.12 - Conclusion: don't install symfony/symfony v4.1.11 - Conclusion: don't install symfony/symfony v4.1.10 - Conclusion: don't install symfony/symfony v4.1.9 - Conclusion: don't install symfony/symfony v4.1.8 - Conclusion: don't install symfony/symfony v4.1.7 - Conclusion: don't install symfony/symfony v4.1.6 - Conclusion: don't install symfony/symfony v4.1.5 - Conclusion: don't install symfony/symfony v4.1.4 - Conclusion: don't install symfony/symfony v4.1.3 - Conclusion: don't install symfony/symfony v4.1.2 - Conclusion: don't install symfony/symfony v4.1.1 - Conclusion: don't install symfony/symfony v4.1.0 - Conclusion: don't install symfony/symfony v4.0.15 - Conclusion: don't install symfony/symfony v4.0.14 - Conclusion: don't install symfony/symfony v4.0.13 - Conclusion: don't install symfony/symfony v4.0.12 - Conclusion: don't install symfony/symfony v4.0.11 - Conclusion: don't install symfony/symfony v4.0.10 - Conclusion: don't install symfony/symfony v4.0.9 - Conclusion: don't install symfony/symfony v4.0.8 - Conclusion: don't install symfony/symfony v4.0.7 - Conclusion: don't install symfony/symfony v4.0.6 - Conclusion: don't install symfony/symfony v4.0.5 - Conclusion: don't install symfony/symfony v4.0.4 - Conclusion: don't install symfony/symfony v4.0.3 - Conclusion: don't install symfony/symfony v4.0.2
J'ai l'impression qu'il me demande de supprimer sensio/distribution-bundle v5.0.25 ?

Quand pensez-vous ?

Merci beaucoup

Avatar du membre
Administrateur PHPfrance
Administrateur PHPfrance | 8627 Messages

29 janv. 2020, 20:18

Moi je ne suis pas un expert en Symfony, mais je dirai qu'il y a un indice dans la 1ère ligne du Readme ;-)
https://packagist.org/packages/sensio/d ... ion-bundle
Quand tout le reste a échoué, lisez le mode d'emploi...

Eléphanteau du PHP | 16 Messages

07 nov. 2020, 18:53

coucou, ton problème technique persiste ?