server symfony

Eléphanteau du PHP | 46 Messages

15 juin 2020, 04:33

bonjour , j'ai une liste d'erreur/warning suite au lancement du serveur symfony :

Code : Tout sélectionner

[Application ] Jun 15 02:25:37 |INFO | REQUES Matched route "home". method="GET" request_uri="https://127.0.0.1:8000/" route="home" route_parameters={"_controller":"App\\Controller\\BlogController::home","_route":"home"} [Application ] Jun 15 02:25:37 |DEBUG| PHP User Warning: Configure the "curl.cainfo", "openssl.cafile" or "openssl.capath" php.ini setting to enable the CurlHttpClient [Application ] Jun 15 02:25:37 |INFO | SECURI Populated the TokenStorage with an anonymous Token. [Web Server/PHP ] Jun 15 04:25:37 |INFO | SERVER GET (200) / ip="127.0.0.1" [Application ] Jun 15 02:25:37 |INFO | REQUES Matched route "_wdt". method="GET" request_uri="https://127.0.0.1:8000/_wdt/96a80c" route="_wdt" route_parameters={"_controller":"web_profiler.controller.profiler::toolbarAction","_route":"_wdt","token":"96a80c"} [Application ] Jun 15 02:25:37 |DEBUG| PHP User Warning: Configure the "curl.cainfo", "openssl.cafile" or "openssl.capath" php.ini setting to enable the CurlHttpClient [Web Server/PHP ] Jun 15 04:25:37 |INFO | SERVER GET (200) /_wdt/96a80c ip="127.0.0.1"
je ne voie pas d'ou cela peut venir, d'autant plus que mon installation fonctionnait bien il y a 3 mois de cela et pas de changement depuis, j'ai tenter de mettre a jour le serveur mais ca n'a rien changer.

autre chose, mon application web ne fonctionne correctement que lorsque Wamp ET le server Symfony sont lancés simultanément, mais pas lorsque l'un des 2 est éteint, est ce normale ?

Avatar du membre
Administrateur PHPfrance
Administrateur PHPfrance | 8627 Messages

15 juin 2020, 14:12

j'ai une liste d'erreur/warning suite au lancement du serveur symfony
je ne voie pas d'ou cela peut venir, d'autant plus que mon installation fonctionnait bien il y a 3 mois de cela et pas de changement depuis, j'ai tenter de mettre a jour le serveur mais ca n'a rien changer.
Tu n'as pas une liste d'erreurs ou de warning, tu n'as que des infos et un un seul warning :
PHP User Warning: Configure the "curl.cainfo", "openssl.cafile" or "openssl.capath" php.ini setting to enable the CurlHttpClient
Du coup, télécharge le fichier de certificats ici : https://curl.haxx.se/ca/cacert.pem et mets le dans C:\wampserver\www (par exemple)
Puis modifier ton fichier php.ini pour mettre :

Code : Tout sélectionner

curl.cainfo="C:\wampserver\www\cacert.pem" openssl.cafile="C:\wampserver\www\cacert.pem"
autre chose, mon application web ne fonctionne correctement que lorsque Wamp ET le server Symfony sont lancés simultanément, mais pas lorsque l'un des 2 est éteint, est ce normale ?
Ne connaissant pas ton installation ni ta config, aucune idée.
Quand tout le reste a échoué, lisez le mode d'emploi...

Eléphanteau du PHP | 46 Messages

16 juin 2020, 02:15

c'est la meme installation que le tuto ici :
https://www.youtube.com/watch?v=UTusmVpwJXo&t=14s :

-installation de symfony website-skeleton via composer
-symfony server installé via l'executable.

Eléphanteau du PHP | 46 Messages

23 juin 2020, 18:22

j'arrive a faire fonctionner mon site avec le WAMP tout seul suite a l'installation de l'apache module pour symfony, par contre, pas moyen de faire fonctionner le site avec le server symfony en standalone, la page d’accueil fonctionne mais les autre page ont des erreur 403 et 404 sur les routes.

[EDIT] le déploiement de symfony est il simple sur un server sans SSH ou vaut il mieux utiliser wordpress dans ce cas ?