[RESOLU] dompdf V 2.0.1 Image not found or type unknown.

Eléphanteau du PHP | 11 Messages

23 nov. 2022, 19:56

Bonjour,

J’ai installé dompdf V 2.0.1 tout fonctionne sauf l’affichage des images il y a l’erreur Image not found or type unknown.

J’ai recherché et mis en place les solution proposées j’ai toujours l’erreur.

Le chemin de l’image est exacte.

Ci-dessous le scripts (extrait)

Code : Tout sélectionner

echo' <table> <tr> <th class="100p" style="text-align:center;"> '.$adresse_lettre.' </th> </tr> </table> <table width="100%" border="0" style="margin-top: 10px;"> <tr> <td class="100p" style="text-align:center;" ><img src="vue_FC_3.jpg" alt="Saint Martin d\'Arenc" width="500px" height="130px" /> </td> </tr> </table> <table> <tr> <th class="100p" style="text-align:center;"> <h2> ADHESION </h2> </th> </tr> </table> ';
le script de la class dompdf

Code : Tout sélectionner

use Dompdf\Dompdf; require_once 'dompdf/autoload.inc.php'; ob_start(); include 'pdf_adhesion.php'; $content = ob_get_clean(); $dompdf = new DOMPDF(); $dompdf->load_html($content); $dompdf->render(); $dompdf->stream("test.pdf", array("Attachment" => true));

Merci pour vos réponse

Eléphanteau du PHP | 11 Messages

24 nov. 2022, 00:21

Une solution 100% compatible pour les pages à convertir en pdf avec html2pdf.

Code : Tout sélectionner

use Dompdf\Dompdf; use Dompdf\Options; require_once 'dompdf/autoload.inc.php'; $options = new Options(); $options->setIsRemoteEnabled(true); $dompdf = new Dompdf($options); ob_start(); require 'pdf_adhesion.php'; $content = ob_get_contents(); ob_end_clean(); $dompdf->setPaper('A4', 'portrait'); $dompdf->loadHtml($content); $dompdf->render(); $dompdf->stream("test.pdf", array("Attachment" => true)); $pdf = $dompdf->output(); file_put_contents("test_Eng.pdf", $pdf);

Je reste toutefois la recherche de html2pdf dejà " monté"et utilisable sans passer par composer.

ynx
Eléphant du PHP | 494 Messages

24 nov. 2022, 13:50

Bonjour,

Pour utiliser html2pdf sans Composer, tu peux télécharger et extraire dans ton projet la version de ton choix sur le dépôt officiel : https://github.com/spipu/html2pdf/releases
Par rapport aux exemples (cf. First Test sur https://github.com/spipu/html2pdf/blob/ ... install.md), il faudra alors remplacer l'instruction require __DIR__.'/vendor/autoload.php'; par une instruction require pour chaque fichier utilisé (par exemple require 'chemin_vers_le_dossier/html2pdf-5.2.5/src/Html2Pdf.php'; pour utiliser la classe Html2Pdf).

Comme suggéré sur une autre discussion, le mieux serait de prendre un peu de temps pour apprendre à utiliser Composer.

Bonne journée,

Eléphanteau du PHP | 11 Messages

29 nov. 2022, 19:53

Bonjour,

Merci pour votre réponse je ne pensais pas qu’il suffisait de changer cette ligne.

Oui vous avez raison, mais comme je l’ai expliqué je ne vais pas faire du développement.
J’ai réussi à passé de php 7.3 à 8. D’ici que le site se sera plus compatible avec la version php je serais remplacé, du moins je l’espère.

Encore merci.