PB Login Pages Chat ScopsEngine

Petit nouveau ! | 2 Messages

15 mars 2017, 18:07

Bonjour, Je viens vers vous cars j'ai un problème avec la page Chat de ScopsEngine impossible de ce connecté a la base de donné pour tant je vois pas d'erreur dans le code .
Voici mon lien : http://chat.onethosting.ga/
Voici un lien qui fonctionne mais qui et pas le mien
https://chat.scops.pro/ .

PS : J'ai explorer son code j'ai juste ajouté une " parce qu’il en manqué une, J'ai même pas le message d'erreur login ou password incorrect et sur l'autre site scops.pro il y à le message d'erreur .

Code HTML Index.html de chat.onethosting.ga
<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
	<link rel="shortcut icon" type="image/png" href="../img/main/ico-2.png">
	<link rel="icon" type="image/png" href="../img/main/ico-2.png">
	<link rel="stylesheet" href="css/fonts.css">
	<link rel="stylesheet" href="style.css">
	
	<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=yes">
	<meta charset="utf-8">
	
	<script type="text/javascript" src="config.js"></script>
	<script type="text/javascript" src="libs/Jquery/jquery.js"></script>
	<script type="text/javascript" src="js/functions.js"></script>
	<script type="text/javascript" src="libs/Form/form.js"></script>
	<script type="text/javascript">
	
		if( getCookie('link') ) window.location = '/chat';
	
	</script>	
</head>
<body>

<div class="container">

	<div class="content-block">
		<div class="services">
			<div class="s-content">
				<a target="_blank"><div class="item mob">Mobile app</div></a>
				<a target="_blank"><div class="item web">Web app</div></a>
			</div>
		</div>
		<div class="table">
			<div class="content">
				<div class="icon-box">
					<div class="logo"></div>
					<div class="chat"></div>
				</div>
				<div class="header"></div>
				<div class="login-box form-box">
					<form method="post" id="login-form" data-action="/php_main/app.php" action="http://onethosting.ga/php_main/app.php">
						<input type="hidden" name="action" value="log_in">
						<input type="text" placeholder="Email.." name="login" class="item input">
						<input type="password" placeholder="Password.." name="password" class="item input">
						<div id="login-btn" class="item submit-button">Login</div>
						<div id="login-res"></div>
					</form>
				</div>
			</div>
		</div>
	</div>
	
</div>

<script type="text/javascript" src="plugin.js"></script>

</body>
</html>

Je vous remercie d'avance .
Cordialement .

Avatar de l’utilisateur
Administrateur PHPfrance
Administrateur PHPfrance | 7234 Messages

16 mars 2017, 00:30

Bonjour,

Il s'agit d'une application commerciale payante.
As-tu contacter leur support ? Car ce sont eux les + à même de t'aider
Quand tout le reste a échoué, lisez le mode d'emploi...

Petit nouveau ! | 2 Messages

17 mars 2017, 19:56

Bonjour,
Oui je les et contactez 3fois aucune réponse de leur part, c'est pour ça que je viens vous .

Je vous remercie .
Cordialement .

Avatar de l’utilisateur
Administrateur PHPfrance
Administrateur PHPfrance | 7234 Messages

18 mars 2017, 01:09

Bah ça va être difficile que quelqu'un puisse t'aider si tu n'as aucun message d'erreur vu que le script que tu utilises est propriétaire et très peu utilisé.

Si tu ne t'en sors pas, tu vas être obligé d'en trouver un autre.
Quand tout le reste a échoué, lisez le mode d'emploi...

Avatar de l’utilisateur
Modérateur PHPfrance
Modérateur PHPfrance | 8755 Messages

20 mars 2017, 11:51

salut,

as tu activé les erreur php ? (error_reporting à E_ALL)
tu peux ne pas afficher les erreurs et les loguer dans un fichier pour le consulter ensuite.

tu as une erreur coté front les identifiants de connexion ne semble pas fonctionner (ouvre la console développeur, F12, tu verras le message).

Code : Tout sélectionner

XMLHttpRequest cannot load http://onethosting.ga/php_main/app.php. The 'Access-Control-Allow-Origin' header contains the invalid value ''. Origin 'http://chat.onethosting.ga' is therefore not allowed access.
ensuite il te faut debogguer ton code pour voir ce qui ne va pas.

as tu indiquer les bonnes informations de connexion pour la base de données ?
bien créé les tables ?

il y a plein de possibilité pour qu'un script tiers ne fonctionne pas et comme l'indique @rthur on ne peut pas t'aider sur ce genre de script sans le code et surtout sans aucun message d'erreur pour te guider dans la recherche.

Perso je commencerais par
- display_error = on
- error_reporting = E_ALL

il faut aussi le tester sur ton poste de dev, est ce que cela fonctionne ? (tu pourras plus facilement suivre le cheminement pour avancer).

@+
Il en faut peu pour être heureux ......