[RESOLU] Installeur PHP4

Mammouth du PHP | 19636 Messages

30 mars 2017, 19:46

Salut tout le monde, voilà bien longtemps que je n'ai pas trainé mes guêtres ici.
Revenir pour demander ça risque fort de paraître bizarre, mais bon :?

Pour un client qui est très très lent à la détente, j'ai besoin de faire une maintenance, donc de pouvoir faire tourner son appli en local, mais son code est en PHP4 8-| et je n'arrive pas à remettre la main sur un installeur de PHP4 en .exe : est-ce quelqu'un aurait à tout hasard une archive sur un antique CD ou encore un lien qui marcherait vers ça ? À la rigueur un vieux WAMP-Server du moment qu'il y a PHP4 dessus.

Merci d'avance pour toute piste.
Codez en pensant que celui qui maintiendra votre code est un psychopathe qui connait votre adresse :axe:

ViPHP
ViPHP | 5882 Messages

30 mars 2017, 23:46

Bonjour,

Tu as regardé sur museum.php.net ?
http://museum.php.net/php4/

Sinon tu peux builder depuis les sources git. ; )

Cordialement

Mammouth du PHP | 19636 Messages

31 mars 2017, 06:24

Salut Sékiltoyai,
Il y a bien des archives sur php.net, encore que le lien que tu indiques soit mort, mais ce ne sont pas les version exe, Quant à faire un build à partir des sources, je n'ai aucune idée de la manière dont il faut « faire ce build » et je ne suis même pas sûr de savoir ce que ça veut dire ;)

Enfin bon, pas grave, j'ai retrouvé un vieux CD de backups avec ce dont j'ai besoin, ça devrait fonctionner sans soucis.

Merci pour tout.
Cyrano
Codez en pensant que celui qui maintiendra votre code est un psychopathe qui connait votre adresse :axe:

Avatar de l’utilisateur
Modérateur PHPfrance
Modérateur PHPfrance | 8755 Messages

31 mars 2017, 15:46

salut,

attention a ta version des sdk de windows, si tu as un windows récent pas sur que ça tourne (je n'ai pas réussi a utiliser de base un php 5.2 sur du W7 ...)

bon courage pour l'archéologie ;)


@+
Il en faut peu pour être heureux ......

Mammouth du PHP | 19636 Messages

31 mars 2017, 16:04

Salut Moogli,
en fait d'archéologie, j'ai ressorti une vieille machine, un vieux portable avec un Windows XP et configuré en PHP4.
C'est pas une bête de course, un Pentium 700Mhz avec 320Mo de RAM, mais ça tourne et c'est suffisant pour ce que je veux faire, en plus de m'éviter de pourrir mon installation actuelle sur W7.

Mais merci pour le rappel :)
Codez en pensant que celui qui maintiendra votre code est un psychopathe qui connait votre adresse :axe:

ViPHP
ViPHP | 5882 Messages

01 avr. 2017, 13:42

Quant à faire un build à partir des sources, je n'ai aucune idée de la manière dont il faut « faire ce build » et je ne suis même pas sûr de savoir ce que ça veut dire ;)
Il n'est jamais trop tard pour apprendre ! : )

Cordialement

Mammouth du PHP | 19636 Messages

01 avr. 2017, 14:18

Pour déboguer du PHP4, je crois qu'il est définitivement trop tard :mrgreen:
Codez en pensant que celui qui maintiendra votre code est un psychopathe qui connait votre adresse :axe: