[RESOLU] Open ssl php 7.2 / 7.3 easyphp

Petit nouveau ! | 3 Messages

28 oct. 2018, 09:44

Bonjour :-)
Je voudrais de l'aide pour activer open ssl en php 7.2 et 7.3 avec easyphp !
En php 7.1, c'est simple, il suffit de supprimer le ";" dans le fichier "php.ini" à la ligne ";extension=php_openssl.dll" dans le dossier EasyPHP-Devserver-17\eds-binaries\php\php713vc14x86".
Sauf que en php 7.2 et 7.3, cela ne semble pas suffisant.
D'après ce que j'ai compris, il y a eu des changements depuis php 7.2 concernant open ssl, donc, je me doute que c'est la cause de mon problème, mais je ne trouve pas de tuto qui aide à résoudre le problème :-(

Merci d'avance de votre aide ! :-)

Avatar du membre
Administrateur PHPfrance
Administrateur PHPfrance | 7783 Messages

28 oct. 2018, 19:58

Bonjour et bienvenue sur PHPfrance ! :-D

Regarde dans les logs Apache, peut être y aura-t-il un message d'erreur qui te mettra sur une piste.
Quand tout le reste a échoué, lisez le mode d'emploi...

Petit nouveau ! | 3 Messages

01 nov. 2018, 12:43

Bonjour et merci :-)
J'ai rien dans les log, c'est bien le problème, il n'y a aucune erreur qui s'affiche :-(
Log apache:
127.0.0.1 - - [01/Nov/2018:11:24:02 +0100] "POST /test3/ecrire/?exec=depots HTTP/1.1" 200 25971
127.0.0.1 - - [01/Nov/2018:11:24:04 +0100] "GET /test3/prive/themes/spip/images/erreur-24.png HTTP/1.1" 200 1452

Log php:
2018-11-01T10:21:56.777362Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-11-01T10:21:56.778354Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.
2018-11-01T10:21:56.778354Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.
2018-11-01T10:21:56.778354Z 0 [Note] --secure-file-priv is set to NULL. Operations related to importing and exporting data are disabled
2018-11-01T10:21:56.778354Z 0 [Note] C:\Program Files (x86)\EasyPHP-Devserver-17\eds-binaries\dbserver\mysql5717x86x180928221818\bin\eds-dbserver.exe (mysqld 5.7.17) starting as process 11272 ...

Bon, je ne comprends pas trop pourquoi il y a une différence pour l'heure, mais sinon, il n'y a que ça...
A savoir que concernant les log apache, j'ai:
LogLevel debug
et que concernant les log php (pour php 7.2.11) ligne 455
error_reporting = E_ALL

Petit nouveau ! | 3 Messages

01 nov. 2018, 21:59

C'est bon, j'ai trouver :-)
En faite, Openssl ne s'active pas en php 7.2 et 7.3 avec la version 2.4.25 d'Apache :-(
Par contre, en mettant à jour la version d'Apache (2.4.37) alors openssl s'active ! Et cela aussi bien en php 7.2 que 7.3 !
Donc, il semble que easyphp 17 à un problème, mais qu'ils ont résolut le problème :-)
L’inconvénient, c'est qu'il faut un compte sur http://warehouse.easyphp.org/ pour obtenir la version 2.4.37, mais bon, par chance, j'en avait un :-)