[RESOLU] php ne s'exécute pas

Eléphanteau du PHP | 18 Messages

19 avr. 2019, 20:18

Bonjour,

Récemment passé à Mint19, j'ai installé LAMP avec la commande :

Code : Tout sélectionner

apt-get install lamp-server^
Tout semble s'être bien passé, et localhost me donne bien la page d'accueil d'Apache.
Par contre, phpinfo.php me donne le code non interprété sous Chromium ("<?php phpinfo(); ?>) et une page blanche sous Firefox...
À noter que pour pouvoir recopier mes anciens sites dans var/www/html, j'ai du modifier les permissions par CHMOD. Peut-être il y a-t-il un rapport ?

Merci de votre aide
Kristen

Avatar du membre
Administrateur PHPfrance
Administrateur PHPfrance | 8339 Messages

19 avr. 2019, 20:37

Personnellement sur Debian/Ubuntu, j'installe séparément les packages Apache, PHP et MySQL/mariadb, je n'ai jamais utiliser le package "lamp-server"

Du coup, essaye peut être d'installer le package PHP avec un truc du genre :

Code : Tout sélectionner

sudo apt-get install php libapache2-mod-php php-mysql
Quand tout le reste a échoué, lisez le mode d'emploi...

Eléphanteau du PHP | 18 Messages

19 avr. 2019, 21:20

Je viens d'essayer. Aucune amélioration...

Eléphanteau du PHP | 18 Messages

23 avr. 2019, 05:56

j'ai essayé un

Code : Tout sélectionner

sudo a2enmod php7.2
réponse :

Code : Tout sélectionner

Considering dependency mpm_prefork for php7.2: Considering conflict mpm_event for mpm_prefork: ERROR: Module mpm_event is enabled - cannot proceed due to conflicts. It needs to be disabled first! Considering conflict mpm_worker for mpm_prefork: ERROR: Could not enable dependency mpm_prefork for php7.2, aborting
du coup les trois commandes suivantes ont rétabli le fonctionnement normal de PHP :

Code : Tout sélectionner

sudo a2dismod mpm_event

Code : Tout sélectionner

sudo a2enmod php7.2

Code : Tout sélectionner

sudo systemctl restart apache2
Merci à tous