Code à modifier suite nouvelle version PHP (variables KO)

3 messages   •   Page 1 sur 1
Petit nouveau ! | 2 Messages

16 juin 2014, 20:32

Bonjour à tous,
Nous avons besoin d'aide pour adapter notre code PHP

Nous avons fait développer un site en PHP il y a 10 ans.
Tout allait bien jusqu'au jour où OVH nous a fait passer dans une version supérieure de PHP qui ne supporte plus notre code.
Impossible de revenir dans une version plus ancienne ; et le changement de .ovhconfig ou de .htaccess n'ont rien fait.

Il semble que l'appel aux variables pré-définies du contexte global dans notre code ne marche plus.
Il faudrait modifier le code pour par ex. utiliser $_SERVER['DOCUMENT_ROOT'] au lieu de $DOCUMENT_ROOT
Il y a 50 fichiers PHP dans le site (mais tous ne sont pas forcément impactés).

Quelqu'un pourrait-il revoir ce code avec une compensation à la hauteur de nos moyens ?

Je vous remercie par avance.

Mammouth du PHP | 1338 Messages

16 juin 2014, 20:41

Bon sinon tu me fais un message privé et on se fait un TeamViewer

Petit nouveau ! | 2 Messages

28 juin 2014, 10:40

Bonjour Elie,

Je n’avais pas vu ton post.
Je te remercie pour ta réponse.

Le site est www.letempsdescerises.net

Dans l’immédiat j’ai mis un index.html temporaire.
Tu ne verras donc pas les messages d’erreur,
sauf en renommant index-ORIGINAL.htm en index.htm

Je te communique les accès FTP et PHP en message privé...

Quoi qu’il en soit, je te remercie sincèrement.

Sébastien

3 messages   •   Page 1 sur 1