installer Tomcat dans l'Eclipse ne fonctionne pas

Eléphanteau du PHP | 48 Messages

13 août 2015, 10:34

Bonjour.

Débutant en programmation côté serveur de Java,j'ai suivi
le tuto ci-dessous pour installer Tomcat,un plugin qui peut traiter une requête HTTP.
http://crunchify.com/step-by-step-guide ... nment-ide/

Mais je trébuche sur la première étape; mon eclipse n'a pas le menu serveur
dans "Window" ! Pour info,j'ai Eclipse IDE for Java Developpers , version : Juno Service Release 2.

J'ai bien peur que ce dysfonctionnement est dû au fait que mon eclipse n'est pas EE,mais SE qui n'a pas de classes serveur.....

Il faudrait que j'installe Java EE sans essayer d'installer des classes serveur dans mon eclipse ?

Si mon sujet est déplacé(c'est un forum pour le frontend,je sais !),je vous demande pardon.

Avatar du membre
Administrateur PHPfrance
Administrateur PHPfrance | 8506 Messages

13 août 2015, 11:34

Bonjour,

Je ne suis pas un expert ni en Eclipse ni en Java mais si effectivement il semblerait qu'il te faille la version "EE" d'Eclipse :
http://www.eclipse.org/downloads/packag ... pers/marsr
Dans le menu "detailed feature list", on voit que le module "org.eclipse.wst.server_adapters.feature" est bien présent dans Eclipse EE, et pas dans Eclipse Classic.

Sinon au début de ce tuto, ils présentent une autre façon de définir un serveur dans Eclipse :
http://blog.paumard.org/tutoriaux/eclipse-tomcat/
Quand tout le reste a échoué, lisez le mode d'emploi...

Eléphanteau du PHP | 48 Messages

13 août 2015, 11:44

Bonjour,cher l'administrateur !

Merci pour la réponse rapide. :D Je vous tiendrai au courant des résultats d'installation. :)